platform.apilevel

From Inspired-Lua Wiki
(Redirected from platform.apiLevel)
Jump to: navigation, search

String value describing the current API version.
Its value can be :

  • "1.0" for OS versions 3.0 and 3.1
  • "2.0" for OS 3.2
  • "2.2" for OS 3.4 (iPad App)
  • "2.3" for OS 3.6
  • "2.4" for OS 3.9
  • "2.5" for OS 3.11 (iPad App)
  • "2.6" for OS 4.0 and 4.1 (iPad App)

Manually setting this property has to be done at the top of the lua script and can only be done once.

Setting a unsupported apilevel has different behaviours when in < 3.6 and >= 3.6:
Before 3.6: The highest supported will be loaded.
With and after 3.6: The highest supported below the requested API level supported will be loaded. But requesting an API level below platform.apilevel = '1.0' will result in the latest/current apilevel available.